Difference between revisions of "1608: Hoverboard"

Explain xkcd: It's 'cause you're dumb.
Jump to: navigation, search
(Secret passages and hidden places: General clean-up, mostly grammar. NOTE: The last paragraph probably should be relocated to the Coins section; unfortunately, I'm out of time for now)
(Characters)
Line 70: Line 70:
 
And possibly even some of the minor characters are used like Danish at the bridge in the Blockade Runner and [[Miss Lenhart]] discovering a bug before the volcano. But neither of these can be confirmed, they just looks like them and has some similarities, like “Danish” teasing the Star Wars fan and Lenhart in some kind of teacher mode.
 
And possibly even some of the minor characters are used like Danish at the bridge in the Blockade Runner and [[Miss Lenhart]] discovering a bug before the volcano. But neither of these can be confirmed, they just looks like them and has some similarities, like “Danish” teasing the Star Wars fan and Lenhart in some kind of teacher mode.
  
The sole exception is the main villain [[Black Hat]] who is not present anywhere in the comic. The only hint that he is not forgotten is that his hat can be seen [http://xkcd.com/1608/1074:-1074+s.png on a stick] under the Destroyer after the three large T-like structures.  And this is not the kind of stick characters Randall usually draws. But at least we now know where Danish has hidden it from him this time (see [[405: Journal 3]]). Given that his hat is stuck there, he could be any of the Cueballs in the game. There is a Cueball close by whistling.  Maybe it is Black Hat trying to call out for his hat… But this comic can not be listed as a Black Hat comic.
+
The only exception is that [[Black Hat]] is not present anywhere in the comic. The only hint that he is not forgotten is that his hat can be seen [http://xkcd.com/1608/1074:-1074+s.png on a stick] under the Destroyer after the three large T-like structures.  And this is not the kind of stick characters Randall usually draws. But at least we now know where Danish has hidden it from him this time (see [[405: Journal 3]]). Given that his hat is stuck there, he could be any of the Cueballs in the game. There is a Cueball close by whistling.  Maybe it is Black Hat trying to call out for his hat… But this comic can not be listed as a Black Hat comic.
  
 
There are also many fictive people from different movies, books and TV-shows (for instance Darth Vader, Gandalf and Steven as mentioned above) and at least one real person: {{w|Elon Musk|Elon Musk's}} who has a [[#Secret passages and hidden places|hidden lair]] under the Volcano.
 
There are also many fictive people from different movies, books and TV-shows (for instance Darth Vader, Gandalf and Steven as mentioned above) and at least one real person: {{w|Elon Musk|Elon Musk's}} who has a [[#Secret passages and hidden places|hidden lair]] under the Volcano.

Revision as of 16:07, 9 January 2016

Hoverboard
hoverboard.png


  • To experience the interactivity of this game, visit the original comic.

Explanation

Ambox notice.png This explanation may be incomplete or incorrect: All images and an explanation and of all items of interest like in 1110 is missing in a table below. More details about the coins (why 169?) and the dimensions (what are the actual size in km, and how fast does the hoverboard then move).
If you can address this issue, please edit the page! Thanks.

The "comic" is actually a browser game made to celebrate the release of Randall's new book, Thing Explainer, which was released on the same day as this comic: Tuesday November 24th 2015. The comic thus appeared on a Tuesday, replacing that week's normal Wednesday release to coincide with the release day.

The title refers to a hoverboard (which resembles a hovering skateboard without wheel) which has been most prominently featured in the movie Back to the Future Part II, which took place in the future, until a little more than a month before this comic was released. Marty McFly traveled to the future in this second installment, more precisely to 2015-10-21, and this comic were released just over one month later 2015-11-24. Hoverboards are just one of many things predicted in Back to the Future Part II, that has not come to pass before reaching the date from the movie. Randall is known to have had electric skateboards, which may be the closest you could get to the hoverboard here.

With Randall's enjoyment with movies and time travels it is very likely that this game is also a tribute to the Back to the Future movies. But the release day of the game has been used to promote his new book (as is clear with the text in the start screen of the game), and this explains why it was not released on the Back to the Future date. Apart from the date of release and the text about the book, the game has no apparent relation to the book. Instead it references several movies and other stuff that has often been featured in xkcd.

The game feature

The game features Cueball riding on a hoverboard. The controls are the left, up, and right arrows as written on the start screen until you begin the game. But there are alternatives as explained in the Controls section. The player can jump repeatedly mid-jump to reach increasing heights, and can move left and right both while jumping and descending (see more under controls).

The player begins in a line-drawing maze (called the play area) with 17 gold coins located throughout and a "deposit" terminal. The ostensible goal of the game is to collect as many coins as possible and return them to the deposit in the fastest possible time, which returns text messages describing the result. Players consumed with obtaining the best possible time result for collecting the coins may not realize there is anything more to the game.

The best way to enjoy this comic is to play the game! If you didn't do that already, reading any below will spoil you from truly enjoying the comic, and maybe make some interesting discoveries yourself! So here is a spoiler alert if you read on.

Beyond the maze on either side (just far enough that players who remain within the maze will not see) are tall walls seemingly designed to contain the player. However, the walls have a finite height and, combined with the ability to multi-jump, the player can leave the purported "play area" either to the sides or above the initial maze. This returns a flashing red error message: "Return to play area".

But if the player overcomes the desire to comply and return to the play area, and disregard this message he can take hoverboard Cueball outside beyond the tall walls surrounding the initial play area. And here he will discover an entire world that can be explored left and right (and above), including numerous points of interest and Easter eggs similar in style to comic 1110: Click and Drag. There are also many more coins to collect, 169 coins all in all, so 152 more than those from the play area.

The main themes

There are many themes and references throughout the game, but the two main themes are Star Wars and The Lord of the Rings.

The largest part of the game is located on the right side of the play area and is mainly a world dominated by references to Star Wars. Most noticeable is a recreation of the opening scene in the first film, where Princess Leia's space ship Tantive IV also known as The Rebel Blockade Runner is flying over the desert planet Tatooine. Here it is followed by the Star Destroyer, Devastator. The desert ground with these two space ships above is the first you find to the right. Although in the game they are located inside the atmosphere, not as in the movie out in space, a fact that is commented on by Megan who looks out from an opening in the bottom of the Destroyers hull.

Megan: Is this ship designed to fly in the atmosphere like this?

Both ships are high above the ground level, but there are wires from the ground that connect (and thus guide you) up to The Runner and from there 100+ torpedoes, which are fired down on the Runner from the Destroyer above, gives away the location of the Destroyer itself. The Destroyer is so high up in the air, that you would not be likely to find it by chance without these leads (or at least some of the several other hints from people on the ground looking up and commenting like White Hat looking up and asking "Uh, what the heck is that?!.").

One of the main points (The Joke) of the entire game is the extreme size of such a Destroyer. It takes up more space than the rest of the game (and most of the coins is located there). Inside the Destroyer there are many many rooms, long corridors and deep shafts, even a huge cave with trees and animals. At the bridge we meet both Darth Vader and the Emperor himself, Palpatine. There are many other jokes related both to Star Wars and other movies and xkcd comics inside the Destroyer. For instance Darth Vader begins to discuss Stevens mom from Steven Universe and Steven himself with family can be found in a different part of the Destroyer.

Darth Vader: But Steven's mother is a crystal gem...

There are also interesting things and references along the ground beneath the space ships, some of these Star Wars related.

To the left side is an entirely different world, although much smaller (shorter) than the one to the right. Here the main theme is The Lord of the Rings mainly with the presence of a volcano where Megan tries to throw in rings of power, as in the scene from the last LOTR film where Frodo fails and Gollum attacks inside the volcano Mount Doom, thus making it clear that the volcano in the game represents this volcano. Both Frodo, Sauron and Gandalf are mentioned in the game. The first two by name in the text (Eagle (Middle-earth)great eagles talking about Frodo and Tolkien, and Sauron's name is read up by Megan from a book), and Gandalf is drawn as a wizard figure in the crater and also his name is used in the message you receive if you collect all possible coins.

The two worlds do conflict though, as an X-wing fighter is parked at a gas station to the left in LOTR world, and Gandalf's famous quote You shall not pass! from his fight against the Balrog is delivered by Cueball trying to block your path to a coin inside a room the Destroyer. This conflict could very well be a reference to the fact that Andy Serkis who played Gollum in LOTR, now plays the Supreme Leader Snoke in the new Star Wars movie, and his appearance as Snoke is not that much different from Gollums. Snoke also delivers a line in the movie (about "bringing someone to me") that reminds allot of Gollum when he talks about "the ring coming to me". Of course Randall would not have know this last part at the time this comic were released. But he would likely be aware of Andy Serkis involvement.

Other themes are related to other movies, like a naughty reference to Star Trek from inside the bridge of the Rebel Blockade Runner where a Long haired girl (maybe Danish since she obviously does this to annoy Star Wars fans) delivers the following line taken from the Star Trek universe: Captain's log, stardate November 24th, 2015...

And there are many references to other xkcd comics, like the room at the front end of the Destroyer with ball pit filled with playpen balls, and two children (or adults) playing in it, like in 150: Grownups. And also the well in the left part of the world with a coin at the bottom is likely a reference to Well series.

There have been many comics with electric skateboards as mentioned, which do not appear in this comic, but there is one example of a normal skateboard. This is used by Megan in a room in the Destroyer, while she is inside a hamster ball, and there is also another hamster ball, used in a more than human sized ten pin bowling game to the left. Another items that has been prominently featured in xkcd.

Also references to video games are seen, best shown with the maze towards the back end of the Destroyer which are an almost complete depiction of Level 1 of the computer game Prince of Persia.

The comic/game and book were released only 3 weeks before the 7th Star Wars movie Star Wars: The Force Awakens were released on December 14 2015. And this movie had already been referenced by Randall 7½ weeks earlier in 1585: Similarities, when another movie (The Martian) were released. It was a reference in the title text to the new robot BB-8 that are featured in the Force Awakens. That the Star Wars section is thus so much larger than the LOTR section may thus also be a hint to the fact that it is now 12 years ago that the last of those films were released, and although the Hobbit has been released as three films over the previous three Christmases it is Star Wars that dominates this Christmas.

In the weeks before, and especially the weeks after there were also other comics that had a subject which could reefer back to Hoverboard in some ways. Maybe these comics were either influenced by the game, or the other way around so that relevant items were added to the game because of these other comics:

  • 1600: MarketWatch - the Washington Monument (an obelisk) is part of the skyline depicted, and this monument is the first that is encountered in the picture when going left from the play area, plus a comment from Cueball:
Honestly, it doesn't even look that muck like Washington.
  • 1610: Fire Ants - in this game there is a giant ant queen inside the Destroyer talking with Cueball about laying eggs:
Cueball: What's up?
Ant queen: The usual. Poopin' out ants.
Cueball: Eww.
  • 1611: Baking Soda and Vinegar - this is about super volcanoes, vs. Mount Doom in the game.
  • 1614: Kites - Megan is seen with a kite in both comics (in this game to the left towards Mount Doom.)
  • 1620: Christmas Settings - another Star Wars reference to lightsaber noises in the title text. Lightsabers are featured twice in this comic, once with Ponytail practicing ion the Blockade Runner, and once with a kid about to hit a Piñata in the Destroyer.
  • 1623: 2016 Conversation Guide - a direct hoverboard reference, and complaint that they are not real yet (only in this game).

Characters

Almost all main characters in the xkcd gallery are used several times, like Cueball, Megan, Ponytail, Beret Guy, Hairy, White Hat and Hair Bun Girl.

And possibly even some of the minor characters are used like Danish at the bridge in the Blockade Runner and Miss Lenhart discovering a bug before the volcano. But neither of these can be confirmed, they just looks like them and has some similarities, like “Danish” teasing the Star Wars fan and Lenhart in some kind of teacher mode.

The only exception is that Black Hat is not present anywhere in the comic. The only hint that he is not forgotten is that his hat can be seen on a stick under the Destroyer after the three large T-like structures. And this is not the kind of stick characters Randall usually draws. But at least we now know where Danish has hidden it from him this time (see 405: Journal 3). Given that his hat is stuck there, he could be any of the Cueballs in the game. There is a Cueball close by whistling. Maybe it is Black Hat trying to call out for his hat… But this comic can not be listed as a Black Hat comic.

There are also many fictive people from different movies, books and TV-shows (for instance Darth Vader, Gandalf and Steven as mentioned above) and at least one real person: Elon Musk's who has a hidden lair under the Volcano.

Furthermore there are many animals, some even rather big, and also a couple of small Star Wars robots, one in a corridor in each space ship.

Extra Hoverboard pages

Transcript

[This transcript only covers the starting page as shown on xkcd: xkcd 1608. There is also an official transcript on xkcd. But on Explain xkcd thesexkcd transcripts are not used. This transcript covers what is on the first image you see when opening the comic on xkcd. A full transcript of the entire comic will be listed on a separate page.]
[Cueball is shown on a hoverboard in the center of the comic. Around him is a simple maze with 12 yellow coins. Another Cueball without hoverboard is shown standing on one of the platforms to the right. The bottom half of the window is black. Right of where Cueball stands is a ramp. Behind the ramp is a terminal. There is lots of space left of the maze, outside the maze. Text is only written in white below in the black area. The first part of the text is written below Cueball on hoverboard. Then there is an arrow pointing to the terminal and a label. Finally there is a line of text at the bottom of the black area.]
[Under Cueball:]
My new book,
Thing Explainer,
comes out today!
To celebrate, here's
a small game.
[Under the arrow below the terminal.]
Deposit coins here
[At the bottom:]
Use the arrow keys to move
[For the full transcript of the entire comic see 1608: Hoverboard/Transcript.]

Trivia

  • There is as usual no title text for these interactive comics. But there is actually one listed in the info page on xkcd. But this text: "Return to the play area", is never shown as a normal title text. But it will erroneously be shown in the unofficial mobile versions of the site.
    • This is actually the text that is shown blinking red at the bottom of the screen when leaving the starting area.

Viewers

Warning: apart from using one of the a full maps below there are also other cheating possibilities where people (or the game) have implemented ways to explore the game world more easily!. The best way to enjoy this comic, however, is to play the game, explore the comic's world the way you're supposed to, get lost in the caves or in the sky, be startled by unexpected things or happy when finding some people or a coin after lengthy exploration through a repetitive landscape. If you didn't do that already, reading any below will spoil you from truly enjoying the comic. So go back to the link above and try that out first.

Standalone application

  • Standalone cross-platform open source remake of hoverboard is available, with some extra features:
    • Off-line play
    • Arbitrary game window size
    • Persistent games state on exit
    • Ability to save up to 10 locations and teleport to them at will
    • Explorable world map
  • Links:

Messages in the starting area

  • Different amounts of coins collected in the play area, will give different messages in yellow on the black part at the bottom of the screen when delivered to the coin collector.
  • Below is a table with examples of what may be written depending on the number of coins. The time (and the amount when there is a range with similar rating) is just chosen at random (although in a realistic range). To get above 17 you of course have to leave the play area and come back again...
    • In chrome and firefox there is not message for those above 9 coins, except 17, 42 and 169. But in Internet Explorer there is still a message for those cases: "Undefined".
    • See screen-shots or click on the links from the number of coins in the table below:
# coins Text when depositing this number of coins

"X" is the number of coins collected

0 coins You got 0 coins in 1 second
You successfully avoided all the coins.
1 coin You got a single coin in 1 second
It's a start.
2-4 coins You got X coins in 3 seconds
Not bad!
5-9 coins You got X coins in 12 seconds
Terrific!
10-16 coins You got X coins in 10 seconds
17 coins You got 17 coins in 15 seconds
You found all the coins! Great job!
18-41 coins You got X coins in 430 seconds
42 coins You got 42 coins in 460 seconds
No answers here.
43-168 coins You got X coins in 460 seconds
All 169 coins You got 169 coins in 1457 seconds
Are you Gandalf?
Return to the play area
  • This message flashes three times over 1.2 seconds (the message only disappears for about 150 ms each time)
  • Then there is a pause for about 1.3 seconds and then this repeats for a total of 5 repetitions, a total of 15 flashes in just about 11.3 second seconds.
  • The message will stop immediately if you re-enter the play area during this period.
  • If you re-enter later it will flash once you leave again.
  • For the program the play area is anything within and below the walls just outside the maze you start in.
    • More precisely you first leave the play area if you pass over the middle part at the top of the walls
    • Or if you make one jump from standing on top of the walls.

Whole Image

Whole Image zoomed very much out, without coins. The part visible at the beginning is marked red.

Secret passages and hidden places

There are many places where you can disappear behind black areas, as not all of these are solid. Some of these places even hide secret passages or hidden rooms.

One notable hidden area is Elon Musk's volcano lair, which is located beneath the lava in the crater of Mount Doom. It can be difficult to find your way in here even if you know it is there. (For more details, see secret passages.)

Another hidden place is the floating rock island that floats high above the Washington Monument, which is located just outside the left edge of the play area. This island is almost impossible to find by chance, as it takes around 30 seconds of repeatedly pressing the Up Arrow key to reach it from the top of the Monument. (The maps can help you if you're having trouble finding it.)

As there are two coins on the floating rock island and four coins in the lair below the lava, it is very hard to find all the coins. There are even several coins that are hard to find because they just float in the air nowhere near any drawn things, or at least no things you can see before seeing the coin. They may hang in the air a few jumps above the ground, or in one case more than a seconds drop below the Destroyer. So getting all coins without help from a map would truly make you a Gandalf-like wizard. (See more regarding coins below.)

Boundaries

The larger game world is physically bounded in the left, right, and down directions, with invisible walls to each side and the ground binding you from going any further down than the deepest depression or hidden caves... In the upward direction, there is in principle also an invisible wall, but while jumping up Cueball on his hoverboard will appear to continue upwards as long as you press to jump, in addition, the longer the up arrow is pressed repeatedly, the longer it will take for Cueball to fall down again once the button is released. So although there are no new things above, you can keep jumping as high as you like and will then fall proportionally longer to get back to where you started out. Until maps were created it could be possible that there could be some hidden unexplored parts, but the maps created already within the first few days covers the entire game.

To the far right is a platform at the top of a high pole. This platform turns out to be a nest (like a stork nest). Above the three eggs are ten coins (the most collected in one place outside the play area, and these are closer together).

To the far left is blond haired girl with a hair bun looking right. In front of her are four coins on a row. She tells about the Destroyer (should you have gone this way without finding it yet).

Girl: In the sky, beyond the mountain, I saw a starship.

Regarding the highest part you find the highest straight rise up in the air to something other than white, under the Rock Island just left of and very high above the Washington monument. Standing on the large rock on top of this floating rock island you are standing almost as high up as possible. There is a coin here one step down from the top of this large rock. This is the highest located coin in the game. Going over the edge also represents the largest possible drop in the game. However this is not the highest point where you can stand, as the very top of the bridge on the Destroyer is just a tat higher. But there is no coin there. Also this is not close enough to the end of the Destroyer that you can jump down to the ground, so the drop from the rock is by far the longest possible.

The deepest part of the lair should have been the lowest point, but as this lair's entrance is up in the volcano crater, it does not reach down to become the lowest part of the image. There is also a deep well (half way left to the Volcano) with a girl at the bottom, that goes just as deep. But the deepest part where you can stand is in the ocean below the Destroyer where a rouge wave is talking to Cueball:

Wave: I know rogue waves seem implausible, but we're a straightforward consequence of the equations of fluid dynamics.
Cueball: ...But you can talk?
Wave: The equations are really complicated.

When standing under this wave you cannot get any lower. There are coins in all three locations, but as the coin is above the top of the high wave, it may be that it is the coin in the well that is the deepest. The coin under the lava is not at the bottom of the room so that is not so low.

Taking a route that takes the hoverboard through all the extremes mentioned above, that is the lowest, highest, left and rightmost coins and solid positions within the game can be done in about 9 minutes and 30 seconds. See a picture here of the coin delivery after such a trip that reached all the boundaries.

All images

  • Coordinates for the images are given in (X, Y) coordinates with the starting point at (1000, 1074).
  • In total there are 3440 images on xkcd that can be accessed via links of this format: http://xkcd.com/1608/1000:-1074+s.png [This link is for for the (1000, 1074) starting point image).
    • Here is a page with a table of all the links to images (still a work in progress): All image links.
    • Note: This is a large page which may take some time to load.
  • The individual images are so small, and cut of at "random" so they do often go straight down through a person, and you can rarely see both a person and the (full) text belonging to them in the same image.
    • See for instance this wedding scene to the right under the Destroyer, which only makes sense when these four images are put together (as there are in the link):
    • It will thus not make sense to make a transcript of all individual images, but instead, only of a complete setting (or maybe a part of a setting.)
  • Maximum possible number of images in the x-direction is 180.
    • Going left will decrease X down to 928 (so 82 pictures left of the starting point in X-direction)
    • Going right will increase X up to 1107 (so 107 pictures left of the starting point in X-direction)
  • Total number of (possible) images in the y-direction is 44.
    • Going down will decrease Y down to 1069 (so 5 pictures down from the starting point in Y-direction)
    • Going up will increase Y up to 1112 (so 38 pictures up from the starting point in Y-direction)
      • The "(possible)" is included because the number of possible active Y-images depends on the X-coordinate, as there are several non-existing images that are not just totally white (i.e. blank images), but which does not even have a number/or active link on xkcd.
      • But the top active image over the floating island and over the top of the bridge section of the Destroyer all have Y coordinate 1112. There are only 20 active images at this Y-coordinate.
  • All possible images are thus spread over a 180 x 44 grid, with a possible 7920 images. But 4480 of these images are none existing on xkcd, but you can travel through them in the game, as they are just shown as completely blank in the game.
    • If you try to load one of the completely blank images like (1000, 1077), three images above the starting point, you will get an error message. There are only 76 (vs 180) images at this Y-coordinate.
      • Note there are several completely empty/white images that are active, but those can be loaded on xkcd like the one below the missing picture mentioned above: (1000, 1076).
    • There are no blank images in completely black areas, like inside structures or under ground. And below Y = 1077 all 180 possible Y-images exist for all X-coordinates, from Y = 1069 to 1076.
      • For instance the image below the starting point is completely black (1000, 1073), and so are the next three below.
      • The bottom images at Y = 1069 has a white border at the bottom: (1000, 1069).
      • All the images at Y = 1069 are the same except the one at the very right edge because at this edge there is also a white border to the right (1107, 1069) (this is not the case to the far left at (928, 1069)).
      • You will never see the images at Y = 1069 in the game. Actually you will neither see anything of the images with Y = 1070 or 1071. And there is nothing that is not completely black for Y = 1069 to 1072. First from Y = 1073 are there active images which includes white.
      • This picture with the wave at (1022, 1073) gives the lowest point where the hoverboard Cueball can actually stand.
      • Since you will sink into the water here, you are almost standing on the top of the Y = 1072 image: (1022, 1072), which is of course completely black.
      • In places where you can stand in a low position on Y = 1073 images you will actually see some part of the images with Y = 1072, not that it makes any difference since they are all black.
  • Here is a list of the places where there are most images at a given X coordinate:
    • At X = 1078, right under the highest point of the Destroyers bridge (1078, 1112) there are 36 active images. Thus even here 8 images are missing between the bottom active image below the Destroyer and the first active near the ground level at Y=1076. (Y = 1077 to 1084 are missing).
    • These missing Y coordinates are active in other places, for instance under the torpedo rain at X = 1020 where all Y images are active up until 1100 - 32 images. But since the last 12 images above this are missing it is still 4 less than under the bridge.
    • Under the floating island, where there are active images at the top Y = 1112, like (990, 1112), there is also the Washington monument below which goes high up, but still there are only 20 active Y images, as there are no active images between 1084 and 1109 (24 missing in between).
    • Over the volcano's edges the highest images directly connecting to solid ground is found at Y = 1087. One image above this is also active making the hight here going up to 1088, thus also making it 20 active Y images. The only not completely white image over the volcano at Y = 1088 is the one with the eagles (956, 1088).

Dimensions

Ambox notice.png This explanation may be incomplete or incorrect: Here should be an overview of how large the picture is (physical distances and time to traverse it. Speed of hoverboard etc.) Could be based on know monuments sizes.
If you can address this issue, please edit the page! Thanks.

List of details and references (with transcript)

Ambox notice.png This explanation may be incomplete or incorrect: Help needed migrating the info into a table with pictures like in here in 1110...
If you can address this issue, please edit the page! Thanks.
  • Begining to change to the coordinates of the images used to make up these structures
Top left image Bottom right Images Description
(944, 1075) (946, 1074) Overview Elon Musk's Volcanic Lair
x: 483735 y: -551990 "What news of the world above? Please tell me - what's hot and viral? What's trending on twitter?"
x: 509587 y: -554621 Washington Monument
x: 509587 y: -554621 Captain's log
x: 552309 y: -560208 A man addressing a giant, supposedly pregnant, ant. Cueball: "What's up?" Ant: "The usual. Pooping out ants." Cueball: "Eww."

This is probably a reference to a part of Orson Scott Card's "Xenocide" in his Ender series. In it, the main character, Ender, visits a hive queen "bugger" he saved on his travels and became friends with, at a time after the queen has settled in on a new planet. At one point, Ender brings other humans to meet the queen at a time when she was giving birth to some of her drones. This is most likely meant to represent a parody of that conversation or else represent a comedic idea of his first conversation with her when she had been birthing, where Ender is alone and is speaking to the Hive Queen. In this version, when he finds out that she is in the process of birthing more ants, rather than being compassionate and understanding with the Queen(as he is in the book), Ender is weirded out like the other humans he brings along with him later.

Areas

  • To begin with different areas was listed using coordinates, that could be found using software. But as these are of no use to the ordinary user, and no one has continued supplying these the list has been moved here as a trivia. This should thus be incorporated into the above tables, and then this subsection should be deleted

Click to expand:


Starting area - (x: 512187, y: -549668)

West / Left

  • Washington Monument - (x: 509864, y: -549746)
    • Invisible entrance through the Monument, indicated by arrow sign
    • Secret entrance into the inside of the Monument, right side, about halfway up - (x: 509815, y: -552614)
      • From there you can fall down to the fault line shown in about the middle of the monument. You cannot see Cueball while he is in the monument in either entrance.
  • Girl in a hamster ball heading for a bunch of bowling pins - (x: 505790, y: -549905)
  • Straight up, a giant floating rock island in the sky (x: 507163, y: -567537)
  • Yet another dig at the Lion King and the lands touched by shadow - (x: 504998, y: -550676)
  • An X-Wing at a gas station, with coin accessible from the left - (x: 503253, y: -551129)
    • Go straight up from the cockpit for a coin, carried by african swallows (non-migratory)
  • A well with a girl at the bottom of it (and one of the yellow game coins), claiming to not be a ghost. A possible reference to Sadako/Samara from Ring (novel,film,remake) - (x: 501998, y: -551030)
  • Landing re-entry capsule with parachutes. Bird on top: "I don't remember laying these but wow they're already flying. Gonna be awesome when they hatch." In capsule: "Yes! My phone has a signal!" "How many new likes did we get during reentry?" "I'm checking!" - (x: 500040, y: -552369)
  • Local Mom discovering This One Weird Bug - (x: 497994, y: -551334)
  • Someone flying a kite, with a coin beside the kite.
  • "The earth is vaping"
  • Climbing the right hand side of the volcano
    • "'The time has come', the walrus said, and put on Sauron's ring" (Lord of the rings/Lewis Carroll reference)
    • "This is currently a V2 but it becomes a V7 if the volcano erupts" (grades of bouldering difficulty, V7 being fairly difficult."
    • "If I don't make it back...tell my wife...where I am...and why you left me there" (reference to lyrics from Space Oddity "Tell my wife I love her very much")
    • Ponytail riding a cycle (a reference to canvas rider?)? (x: 490610 y: -554364)
    • LOTR Eagles - (x: 489661 y: -556811)
  • Right-hand rim of the volcano
    • A periscope peeking out of a shallow lava pool near two people playing "the lava is a floor". Reference to a common child's imagine game where the floor is lava (see 735: Floor) - (x: 488573 y: -556337)
    • "One of these is probably a ring of power or whatever" - throwing some things, possibly rings, off the edge of the volcano, in anti-climactic reference to climax of Lord of the Rings series.
  • Lava in the centre of the volcano
    • A dark grey ocean that isn't noticeable until you fall in
    • "Remember: there's no such thing as good volcano footage taken by a quadcopter that survived", quadcopters inverting the typical safety warning for camera operators - (x: 486640, y: -554838)
    • Elon Musk's Volcano Lair - (x: 484167, y: -549462)
      • entrance hidden under volcano lava, before reaching Artex - (x: 483791, y: -551292)
      • "What news of the world above? Please, tell me - what's hot and viral? What's trending on Twitter?!!" - a person in cave being very non-hermit like.
      • "I always assumed Elon Musk's volcano lair would be, like ... tropical. And ... well, pleasant." - "Back to your desks, swine". Strange dystopian scene in cave.
      • "So this is where it is", an electronics "ground" symbol, that presumably all grounded electronics are connected to - (x: 485125, y: -549062)
    • "Artex!", a horse stuck in the lava (a reference to Artax, the horse in Neverending Story) - (x: 483715, y: -554354)
    • A wizard, Gandalf?
  • Climbing out of volcano
    • A cave, with a crouched figure, saying "Goooooold! Goold!" with money bags around. (reference to the 1982 video game The_Hobbit_(1982_video_game))

y: -554877)

  • Descending far side of volcano
    • Basketball hoop, with coin. One player says "Ok, as soon as it erupts, go for the dunk. Our sweet moves will be preserved for all eternity", possibly a reference to preserved lavafied bodies in Pompeii - (x: 479523,
  • *"In the sky, beyond the mountain, I saw a starship" - referring to the huge Imperial Star Destroyer on the right/east of the play area, and Legolas.
  • ?Hat underground
  • ?A hole which traps(?) the player unless noclip mode is used

East / Right

  • People holding anchor lines to the Tantive IV (Star Wars: A New Hope), being attacked by an Imperial Star Destroyer - (the people: x: 518954, y: -549056)
  • Desert with dunes - (x: 520000, y: -549114)
  • Ocean Yelper (giving only 2.5/5 stars) - x: 522015, y: -549015
  • Talking Rogue Wave - (x: 523460, y: -549013)
  • Wedding - (x: 531558, y: -549386)
  • Graveyard - (x: 534140, y: -549546)
  • Remains of Ozymandias' Statue - (x: 535927, y: -549666)
  • Huge pyramid - (x: 538167, y: -550906)
  • Blackhat's hat on a stick - (x: 549997, y: -549777)
  • Whitehat's head in the grass? - (x: 559826, y: -549847)
  • Giant bird nest - (x: 567123, y; -550417)
  • Beret Guy riding a torpedo (Dr. Strangelove) - (x: 522754, y: -554342)
  • Medusa? - (x: 557434, y: -549743)

Rebel Blockade Runner

Up in the air is the CR90 Corvette, Tantive IV aka Rebel Blockade Runner with Princess Leia from the start of the original Star Wars movie.

  • Coordinates:
    • ??
  • Cueball is standing at a ledge with a fishing rod with something on the hook somewhere below the spaceship. Two birds are circling the line.

Imperial Star Destroyer

High up in the air there's a huge spaceship.

  • Coordinates:
    • top left at (513072, -560660)
    • bottom left at (513080, -559470)
    • top at (552154, -569022)
    • top right at (556557, -567711)
    • bottom right at (558244, -556542)
  • Entrances (from bottom left clockwise):
    • Tunnel at (513080, -559680)
    • Tunnel at (513166, -560434)
    • Shaft at (516560, -560912)
    • Shaft at (519200, -561108)
    • Shaft at (525255, -561527)
    • Shaft at (527990, -561844)
    • Shaft at (533087, -562298)
    • Shaft at (539637, -563233)
    • Tunnel at (540958, -563721)
    • Shaft at (543789, -564670)
    • Stairwell down at (547438, -565058)
    • Tunnel at (552319, -566184)
    • Tunnel to an isolated small room at (557774, -562042)
    • Shaft at (556350, -556720)
    • Glitchfloor at (547890, -556779)
    • Shaft at (543850, -557500)
    • Main ramp at (537260, -557969)
    • Tunnel at (531840, -558547)
    • Parachutists' ramp at (526624, -558664)
    • Ramp at (525300, -558747)
    • Shaft at (520440, -559100)
    • Shaft at (516825, -559300)
  • Interesting objects and places inside:
    • Steven Universe and the Crystal Gems - (x: 551664, y: -567383)
    • A nearly complete depiction of Level 1 of Prince of Persia - (x: 551532, y: -563512)
    • Emperor Palpatine Park and Gazebo - (x: 546819, y: -559584)
    • Dancers (possibly spinning counter-clockwise) dancing to piano music - (x: 547536, y: -563301)
    • Octopus guarding two coins - (x: 531646, y: -559663)
    • A sign saying "Caution GlitchFloor" (falling straight down through it nets you a coin someway down) - (x: 547898, y: -556784)
    • A huge light bulb - (x: 555405, y: -557769)
    • The Emperor birdwatching - (x: 554777, y: -567346)
    • Ponytail recreating Joust on an ostrich - (x: 552048, y: -568045)
    • A party on the ceiling (negative gravity?) - (x: 550350, y: -564354)
    • A huge ant - (x: 552309, y: -560208)
    • Tube slide - (x: 541813, y: -563721)
    • A reservoir (?) with hidden passages - (x: 541300, y: -560330)
    • A huge spark gap (?) - (x: 541900, y: -558110)
    • Torpedo launcher room - (x: 529627, y: -558481)
    • A Tetris block falling - (x: 529414, y: -529220)
    • Lightsaber Piñata party - (x: 515353, y: -560329)
    • Swimming pool - (x: 517346, y: -559831)
    • Children's swimming pool (ball pit?) - (x: 514500, y: -560436)
    • A crocodile - (x: 553623, -568091)
    • Spiral tunnel - (x: 543320, y: -558314)
    • A car - (x: 537750, y: -557937)


References by Category

Coins

  • There are 169 coins.
    • Here should be more details about the coins and where they are located and how many.
  • For more details see here for coins location.

Technical aspects

As previously noted, the comic bears considerable resemblance to 1110: Click and Drag. The comic is made in much the same way, with 'drawn' images "glued" together to form a large "map", with the illusion of infinite bounds made possible through space saving techniques where blank tiles are not stored and are instead painted white. The boundary between blank squares and 'drawn' squares is made clear as any white space in the normal images has a very slight grey tint. Thus, seams between images and blank spaces can be discerned.

The tiles for the map are stored as simple PNG files in the naming scheme: X:Y+s.png. An example can be seen here: http://xkcd.com/1608/1013:-1096+s.png Each file is 513x513 pixels in size, one pixel is reserved as overlap to ensure seamless joining of images. So far, through experimentation, tiles in the range 928 to 1108 X and -1112 to -928 Y have been discovered, internally, the position of the player is divided by 512 and rounded down to give the position of the tile.

The collision map is encoded in the darkness of the black. Using an image manipulation program, one can easily find the secret pathways even in the zoomed out maps provided below by enhancing the contrast of the dark areas.

The game was made by Max Goodman who has previously worked on 1416: Pixels. The source code for the game can be found here.

Functionality

By observing page code while playing, the game grabs and displays images based on location, and subsequently clears all non-visible images. The game uses what seems to be a position syntax to retrieve the intended images live, and returns an error if such an image does not exist, such as a blank area. This technically means things could be added to the world and updated live. If the player is moving sufficiently fast or if the internet connection is slow, this means that the player can get stuck in a black area that does not load in time.

This also means that the game does not have coded top or bottom limits, so any attempt to find the ceiling of the game will be futile unless the game is tweaked. The game does however have side limits.

Opening the console will display the text: what? hoverboard not enough for you!? in the log. Activating goggles mode will cause the text 'B-)' to appear in the log.

Bugs and errors

  • On a slow connection, it's possible to move into an 'open' area and then the black image loads in and (probably permanently, without tricks) traps you immobile.
  • Sometimes the timing of the game is completely off. This can make the Cueball move extremely slowly. Or on the other extreme make him go faster so the images jumps and makes the graphic look horrible.
    • This error was actually used to discover something about how you move when pressing the arrows - see under Controls.
  • If the focus switches from the game to the page, the Cueball can freeze in midair. The same thing can happen if the window border overlaps the play area.

Controls

The keyboard controls are as follows:

  • Go Left - Left arrow key, a or h
  • Go Right - Right arrow key, d or l
  • Go Up (jump or hover) - Up arrow key, w, or k
  • Go Down (if gravity disabled) - Down arrow key, s, or j

This control scheme covers the three commonly used directional key sets: WASD a set of keys commonly used by modern games; HJKL a set of movement keys used by vi and applications which attempt to mimic vi key controls (vim); and the arrow keys, the most generic set of keys which is usually accepted by most applications which take movement as input, these were commonly used in older games.

On devices which have a touch screen and tilt sensor (portable devices like mobile phones and tablets) the controls are as follows:

  • Go Left - Roll the device anticlockwise
  • Go Right - Roll the device clockwise
  • Go Up (jump or hover) - Tap the screen

After inspecting the source code, there appears to be no way to move down on a portable device, this is only relevant if gravity is disabled (see Cheats and Exploits).

  • If you keep down the left/right control you will keep moving along in that direction as long as no object blocks you.
  • A jump will only take you a certain height.
    • Then you drop down.
    • The jump is fast to begin with, then gravity stops you and revert the direction.
    • When descending again you accelerate to begin with but quickly reach a terminal velocity.
  • If you jump repeatedly while keeping a left/right control down you will jump in that direction.
    • But if you only jump one time, while keeping down the direction control, then you will stop moving forward after about 2.8s, from then on you will just keep falling straight down, or stop where you reached if on the ground.
    • This makes quite a difference when you jump into an opening from a high structure. If the background is completely white, you cannot see that you do not continue to move forward, and will thus not be aware that you are now falling straight down, instead of going left/right.
    • It can actually be quite difficult to notice as you will leave any structures that can indicate this issue very quickly.
      • Of course if you notice that you land much too close to some high structure from where you base jumped, you will begin to understand. For instance falling off the floating rock, and not moving away from under neath it during that long fall.
      • The timing was discovered because of one of the bugs in the program that sometimes makes Cueball move extremely slow, so one jump takes more than 3s.
    • The solution if you wish to keep moving to either side while descending, is that after the jump, you release and repress the left/right control. Then you will continue moving in that direction as long as you do not jump again.
    • As long as you continue to jump you will also keep moving laterally if you keep one of those buttons down. The is quite counter intuitive.
      • This also means that when you jump up over a long distance (or continue to jump hover over the landscape), you will not have this issue, since every jump reactivates the lateral movement.
      • But if you jump over a small obstacle and then just keep another arrow down, you will soon stop, which could fool you into believing that it was an obstacle on the ground that held you back.

Cheats and Exploits

Aside from the obvious ability to move out of bounds in the game, there are some more obscure hidden features which can't be enabled through normal gameplay, the ones found so far are as follows:

Modes are activated by opening the Javascript Console (F12 [Or Command-Alt-I in most browsers under Mac OS X] to open Developer Tools, then Console tab) and writing corresponding commands.
Click to expand:


  • Gandalf Mode: i.am.gandalf = true - jumps and runs further. displays a white gandalf hat that works well in places where the avatar can't be seen.
  • Speedhack: explorer.opts.speed= *Value* - Speed hacking, with 1 = normal speed
  • Jump Hack: explorer.opts.jumpForce= -*Value* - Jump hacking, with -1 = normal jump (positive values cause the hoverboard guy to move down when jumping)
  • Mewtwo mode: mewtwo = true - disables gravity
  • Noclip mode: noclip = true - player is able to move around the map without collision. Combine with Gandalf and Mewtwo modes for free easy map traversal.
  • Goggles mode: ze.goggles() - displays a small window showing area around the player in a pixelated manner. The goggles indicate collision boundaries (where the player touches the world) in cyan lines. Black pixels that are passable (such as other characters or text) will be highlighted red (allowing secret passages to be discovered).
  • Position Tracking: explorer.pos - Returns the player location to the console. Can be used to track position and test to ensure you are still moving. Must be re-entered to compare positioning.
  • Position Setting: explorer.pos.x = *Value* or explorer.pos.y = *Value* - Can be used to manually set a position within the world. The start is at x: 512106, y: -549612. The left terrain bound is at x: 475210, y: -553711. The right terrain bound is at x: 567281, y: -549712. Mewtwo and Noclip modes are a must for exploring in this way.
  • All the above: explorer.opts - Contains all the game's parameters. You can directly mess with gravity, collision (disableCollision), jump force (jumpForce) and speed (maxSpeed), among others. Run Object.keys(explorer.opts) to list all available parameters you can tweak.
  • List all coins: explorer.objects - Array containing the position of the 169 coins of the game.
  • Disable tilt input: getEventListeners(window)['deviceorientation'][0].remove() - on Macs with motion sensor, disables tilt input which causes problems controlling the avatar

Getting All Coins: To instantly get all coins, input the below into the console window. Does not use standard formatting of [i] to avoid conflicts with i.am.gandalf

   for (var T = 0; T < explorer.objects.length; T++) {
       explorer.objects[T].got = true;
   }

To teleport to the next coin every time you press the left or right arrow:

   var T = 0;
   document.onkeydown = function(event){
     if (event.keyCode == 37) { T = T-1 }
     else if (event.keyCode == 39) { T = T+1 }
     else { return }
     T = T % explorer.objects.length;
     var coin = explorer.objects[T];
     explorer.pos.x = coin.x1; explorer.pos.y = coin.y1;
   }

For a quick tour of all the coins:

   var delayInMilliseconds = 1000; // 1 second delay between each teleport. feel free to change this.
   var index = 0;
   explorer.objects.forEach(function(x){
     setTimeout(function(){
       explorer.pos.x = x.x1;
       explorer.pos.y = x.y1;
       x.got = true;
       explorer.frame(); // forces a redraw
     },
     (index + 1) * delayInMilliseconds);
     index++;
   });

To see a list of coin coordinates you have not yet collected:

   var L = 0;
   for (var S = 0; S < explorer.objects.length; S++) {
       var I = explorer.objects[S];
       if (I.got) {
           L++;
       } else {
           console.log(I.x1.toString() + ", " + I.y1.toString());
       }
   }
   console.log("You've found " + L.toString() + " of 169 coins");

To display the distance and direction to the closest coin (with inverted colors once you have all the coins):

   function distance(x1, y1, x2, y2) {
       var dx = x2 - x1;
       var dy = y2 - y1;
       return Math.sqrt(dx * dx + dy * dy);
   }
   
   function angle(x1, y1, x2, y2) {
       var dx = x2 - x1;
       var dy = y2 - y1;
       return Math.atan2(dy, dx) * 180 / Math.PI;
   }
   
   function renderRadar() {
       var mindist = 10000000000;
       var closest = {
           x1:512278.0, y1:-549613.0
       };
       var linecolor = "red";
       for (var S = 0; S < explorer.objects.length; S++) {
          var I = explorer.objects[S];
          if (!I.got) {
              var dist = distance(explorer.pos.x, explorer.pos.y, I.x1, I.y1);
              if (dist < mindist) {
                  mindist = dist;
                  closest = I;
              }
          }
       }
       if (mindist == 10000000000) {
           mindist = distance(explorer.pos.x, explorer.pos.y, closest.x1, closest.y1);
           if (document.getElementById("radar").style.backgroundColor != "red") {
               document.getElementById("radar").style.backgroundColor = "red";
           }
           linecolor = "green";
       } else {
           if (document.getElementById("radar").style.backgroundColor != "green") {
               document.getElementById("radar").style.backgroundColor = "green";
           }
       }
       var ang = angle(explorer.pos.x, explorer.pos.y, closest.x1, closest.y1);
       var indicator = "";
       if (ang > 112.5 || ang < -112.5) {
           indicator += "left";
       }
       if (ang < 67.5 && ang > -67.5) {
           indicator += "right";
       }
       if (ang > -157.5 && ang < -22.5) {
           indicator += " up";
       }
       if (ang > 22.5 && ang < 157.5) {
           indicator += " down";
       }
       document.getElementById("radar").innerHTML = "Distance: " + mindist.toFixed(1).toString() + "<br/>";
       document.getElementById("radar").innerHTML += indicator + " (" + -ang.toFixed(1).toString() + "°)";
       document.getElementById("radar").innerHTML += "<div id='circle' style='border: 1px solid black; border-radius: 50px; width: 100px; height: 100px; position:absolute; top:50px; left:25px'/>";
       document.getElementById("radar").innerHTML += "<div id='line' style='width: 50px; height: 1px; background-color: " + linecolor + "; position:absolute; top:100px; left:75px; transform:rotate(" + ang + "deg); transform-origin:0% 0%'/>";
   }
   
   var d = document.createElement("div");
   d.id = "radar";
   d.style.position = "fixed";
   d.style.left = "0px";
   d.style.top = "0px";
   d.style.width = "150px";
   d.style.height = "160px";
   d.style.border = "1px solid red";
   d.style.zIndex = "2";
   d.style.backgroundColor = "green";
   d.style.color = "#8f8";
   document.body.appendChild(d);
   
   setInterval(renderRadar, 100);

To display your current coordinates:

   function renderRadar2() {
       document.getElementById("radar2").innerHTML = "x: " + explorer.pos.x.toFixed(1).toString() + "<br>y: " + explorer.pos.y.toFixed(1).toString()
   }
   
   var d = document.createElement("div")
   d.id = "radar2"
   d.style.position = "fixed"
   d.style.left = "150px"
   d.style.top = "0px"
   d.style.width = "150px"
   d.style.height = "35px"
   d.style.border = "1px solid red"
   d.style.zIndex = "2"
   d.style.backgroundColor = "green"
   d.style.color = "#8f8"
   document.body.appendChild(d)
   
   setInterval(renderRadar2, 1000)


comment.png add a comment! ⋅ comment.png add a topic (use sparingly)! ⋅ Icons-mini-action refresh blue.gif refresh comments!

Discussion

Well, this will be the next incomplete explanation for a while. -162.158.90.165 21:58, 24 November 2015 (UTC)

Still working on it now four months later. But not many other helping with it. ;-) Getting closer to the end though with the table in place. --Kynde (talk) 14:10, 26 March 2016 (UTC)

Yes, one thing to note is how to get the hell out of the cave near the volcano 108.162.249.159 22:38, 24 November 2015 (UTC)

The image is made up of small images with addresses of the form http://xkcd.com/1608/XXXX:-YYYY+s.png (although not every coordinate inside the bounds has an image associated). A script could probably dump out all the images and paste them together. --108.162.216.6 22:46, 24 November 2015 (UTC)

West -- Under Lava Pools -- Elon Musk's Secret Volcano Base (not as enjoyable as you might expect).

The Starship out east contains, among other things, Darth Vader, apparently explaining Steven Universe to a subordinate. (Steven and the Crystal Gems can be found a the west end of the ship, near an ice cream cooler.) The same ship contains an elaborate homage to the original Prince of Persia. 162.158.56.5 (talk) (please sign your comments with ~~~~)

There, have at thee an image! Arch-TK (talk) 22:58, 24 November 2015 (UTC)

"teleport to next coin" code doesn't work(insert name here) (talk) 14:47, 21 June 2019 (UTC)

There are 168 coins spread throughout the map according to the source code 173.245.54.53 23:03, 24 November 2015 (UTC)

It's actually 169 coins (t.length). --188.114.111.129 23:22, 24 November 2015 (UTC)

May I change the code for the display distance and direction thing to make the colors more appealing? I want to cheat but I don't want to stare at that yucky green the whole time. 172.69.170.88 17:44, 20 June 2019 (UTC)

When using a device, instead of saying "use arrow keys to move", it says "tilt to move, tap to jump". It's also a lot harder to control. 108.162.250.159 (talk) (please sign your comments with ~~~~)

What kind of device and is this through the normal xkcd home page? It does not work on my tablet by going to xkcd (anroid, leonov tablet). --Kynde (talk) 17:24, 16 December 2015 (UTC)

I got 153 coins!! :D There's two starships, one's a star destroyer with an expansive maze dropping regular torpedoes on the other. May be noteworthy that there are various references to Star Wars and Steven Universe throughout. 108.162.221.13 23:27, 24 November 2015 (UTC)

The second starship is the TantiveIV, Leia's ship at the beginning of episode 4. Note directly below the Tantive, the terrain seems to be sand dunes. Also there are two more space ships by the volcano; an X-wing at a gas station and an Apollo Command Module. 108.162.216.24 (talk) (please sign your comments with ~~~~)

https://xkcd.com/1608/tigl.js - Looks like there's an easier to read version of the code there. Maybe that'll help someone with extracting all the images. {{unsigned ip|

I've got all the images downloaded. Zipping/uploading now. Should I post a link here when complete or what's the best way to share these? I'm also working on setting up a zoomable map. 173.245.54.53 23:57, 24 November 2015 (UTC)

The collision detection is glitchy. I keep landing/bumping against platforms I'm far away from. Is getting stuck against walls normal? --199.27.130.234 00:01, 25 November 2015 (UTC)

Yes, getting stuck against walls is normal. If the wall has at least 1 pixel sticking out under the hoverboard, then that pixel will be treated as the floor, and the hoverboard will stop falling. This is easier to see in goggles mode.108.162.216.118 13:15, 29 October 2016 (UTC)

Tiles are located here in a zip: https://up1.ca/#Gi51KPFyPRELe0T1D6q9Mw All I did was iterate over http://xkcd.com/1608/X:-Y+s.png from X=[916...1116] and Y=[916...1116]. I'm working on putting a zoomable map together. If anyone has interest in helping we could hop on IRC? Jcox (talk) 00:15, 25 November 2015 (UTC)

This was great. But the zip file misses all images in column 1019-1021 as well as the 6 lowest images of 1022 (X coordinates 1019-1022, all Y coordinatesin the first three and then 6 lowest Y coordinates in the last). It was managable to download the last with my click skills. So thanks anyway. --Kynde (talk) 20:15, 28 December 2015 (UTC)

I've written a zsh script to iterate over all possible tiles (does anyone know the height limits? the source only gives the left and right limits) and glue them together into one giant file. I'll upload the results as soon as it's finished. Arch-TK (talk) 00:17, 25 November 2015 (UTC)

I don't think it's limited vertically at all. I found a zoomable map on the reddit topic http://codepen.io/KyleDavidE/full/605dc87b614ff6b2bd716f4c6f640203/ (by kyledavide) Miraries (talk) 00:21, 25 November 2015 (UTC)Mirages

Here's a zoomed out map of all the game area: https://i.imgur.com/rNU9ZgN.png. From luke_in_the_sky at Reddit [1]. --188.114.111.129 00:35, 25 November 2015 (UTC)

Alright, the full png of the entire map is almost finished, I should have used white tiles as blank tiles but I guess I can fix that up in gimp, and I'm not sure how to account for the 1 pixel overlap with just imagemagick convert. The last step is to merge allthe layer images into one giant image, wish my laptop the best of luck! Arch-TK (talk) 01:00, 25 November 2015 (UTC)

Someone beat you to it, but keep on it: that one doesn't have right limit tiles. https://www.reddit.com/r/xkcd/comments/3u4sy1/xkcd_1608_hoverboard/cxc0p8x --188.114.111.129 01:19, 25 November 2015 (UTC)

Perhaps we can change the screenshot at the top to this? It's a quickly hacked overview of the entire map: http://imgur.com/Mz9arHz 199.27.129.167 01:27, 25 November 2015 (UTC)

I think it might make more sense to just add it as another image, mediawiki supports this after all. The syntax should be: [[File:filename.png|thumb|Subtitle|alt=alt]] Arch-TK (talk) 01:34, 25 November 2015 (UTC)


[2] This one loads all of the images quickly (From the xkcd site), and uses browser zooming. 173.245.54.47 01:29, 25 November 2015 (UTC)

The impassible backgrounds are RGB(0,0,0), and the passable ones are RGB(1,1,1). #explore > :first-child {filter:brightness(30);-webkit-filter:brightness(30);-moz-filter:brightness(30);-o-filter:brightness(30);-ms-filter:brightness(30);} ... See https://twitter.com/BadPhysics/status/669354631869304832 108.162.249.155 03:40, 25 November 2015 (UTC)

Here are all the secret passages marked I could find: http://imgur.com/a/fKE1Q --162.158.91.220 00:50, 25 November 2015 (UTC)

I wrote a tampermonkey script that shows you your coordinates and lets you teleport; will make coordinate sharing a lot easier. You do need tampermonkey installed for this to work. Click to install Minerguy31 (talk) 04:17, 25 November 2015 (UTC)

I got 159 coins without the map. If you guys are still wondering how to escape the volcano, move to the right for as long as you think you can, then start spamming the up key while switching between holding the left and right keys. It worked for me on my first try.162.158.252.119 07:06, 25 November 2015 (UTC)

Didn't take down the coordinates, but the layout to the first level of the original Prince of Persia is in there, including the guard standing by with his scimitar! I found it in the ship atop the pyramid east of the play area. --108.162.218.245 06:24, 25 November 2015 (UTC)

Just thought this was interesting, when you "complete" the game by dropping coins, the following line of javascript is run, which sends your result to the server (L is number of coins, z is seconds used): (new Image).src = "//xkcd.com/events.gif?coins=" + L + "&seconds=" + z; Don't be tricked by the .gif extension, it doesn't show an image when opened, and the server probably handles this request by logging it to somewhere. 141.101.80.87 (talk) (please sign your comments with ~~~~)

It actually returns a 1 by 1 pixel white GIF. Arch-TK (talk) 13:14, 25 November 2015 (UTC)

Is there a way that we can merge the "game" part of this comic with the map of 1110: Click and Drag? Allowing us to explore that one in a similar way? Bon (talk) 11:03, 25 November 2015 (UTC)

Well I managed to find (nearly) everything, except the floating rock island, and 162 coins without the map, but even with looking at several maps, I didn't pass any graveyard nor found the way to the grey ocean, which I assume is underneath the "continent". Does anyone know where the entrance is? 162.158.90.218 11:54, 25 November 2015 (UTC)

Search for any missing things in the complete 1608: Hoverboard/Transcript, and you shall find what you seek. --Kynde (talk) 17:40, 16 December 2015 (UTC)

Just thought I should say; the comic supports some alternative movement controls, there's the arrow keys, WASD, and also the vi keys (hjkl), and the numpad (8426). 108.162.242.125 13:29, 25 November 2015 (UTC)

I was not able to get to some points because they were surrounded by text, people or other objects. Is that normal, or are there tricks to get to every coin without using cheats (console)? It would be nice if this could be mention / explained in the article. 162.158.135.35 13:31, 25 November 2015 (UTC)

In some cases you can come in from the side as opposed to trying to come down through or up through something. Example: at the X-Wing "gas station", to get that coin, land on the ground to the left of the X-Wing and move to the right on the ground towards the gas station. Jarod997 (talk) 14:45, 25 November 2015 (UTC)
No text is solid! You can use the full 1608: Hoverboard/Transcript to find out how to get to every coin and place (or the great map linked at the top). --Kynde (talk) 17:40, 16 December 2015 (UTC)

The list of "areas" in the map would be much easier to read, and much easier to correlate with the map, if the origin were set to the starting area (that is, if the coordinates of the starting area were set to x:0, y:0). What is the reason for the very large numbers? --BlueMoonlet (talk) 15:50, 25 November 2015 (UTC)

The large numbers are the actual ones used by the game code and displayed by the hacked-up "radar" so it was a natural choice to use them as they are. We could define some origin and count coordinates from it but we would have to agree on its position and then change the "radar" code and recalculate all coordinates written down already. -- 162.158.90.224 08:53, 27 November 2015 (UTC)
Coordinates is not very helpful to most people. It should more be in relation to the objects you pass. Either you just look at one of the maps (and then past the pyramid or in the volcano makes sense) or else you actually try the real experience, and again after the ocean comes a pyramid makes more sense than coordinates. Have moved this section to a trivia section. The table should be build differently. That is still work to be done. All things are at the moment mentioned in the complete 1608: Hoverboard/Transcript. --Kynde (talk) 17:40, 16 December 2015 (UTC)

The starting area is in no way related to pac-man. The lines are not all right angles, there is a timer, there's gravity, there are no aggressors, you're collecting coins instead of pellets.... Not every line maze is pac-man. This is an erroneous reference that should be removed. --198.41.235.167 17:16, 25 November 2015 (UTC)

The source code found at https://xkcd.com/1608/tigl.js does not seem to be complete. I would personally work on de-obfuscating the full source code using the fragment found there but technically the source is covered by implicit copyright laws and that means that if I published a derived work I would be breaking those laws. Should I just change the line from "The source code can be found at ..." to "The full (obfuscated) source code can be found at ...tigl.min.js and a deobfuscated piece of the source code can be found at ...tigl.js". Arch-TK (talk) 18:28, 25 November 2015 (UTC)

I added quick coordinate / teleport access on right-click to the quick hack map. Kyledavide (talk) 20:45, 25 November 2015 (UTC)

Can't be bothered working out how to edit the page, but the explanation contains the phrase "People holding anchor lines to a Star Destroyer" - they're holding anchor lines to a CR90 Corvette, specifically the Tantive IV, commonly referred to as the "Rebel Blockade Runner", which in turn is being *attacked by* a Star Destroyer. I'll get my coat. 162.158.153.47 (talk) (please sign your comments with ~~~~)

That's no 'Children's Swimming Pool', it's a ball pit! 162.158.2.222 23:46, 25 November 2015 (UTC)

If it is, it's filled with water as well. There are waves on the surface and fish live in it. -- 162.158.90.224 09:00, 27 November 2015 (UTC)

I slightly improved the "direction to next coin"-code by displaying a compas. Code can be found here http://pastebin.com/PL6fv5XK . I'm new to this wiki and don't want to mess up the page, so I didn't put the code in there myself ... --162.158.90.209 00:01, 26 November 2015 (UTC)

Haven't read all the comments above so maybe someone has written about it? If you click up it seems to count how many times. So it will just show white and then when you release again, it will take longer to hit the ground the longer you have pushed up. Tried with 100 clicks (9-10 seconds) and 200 clicks (20 seconds). I got about 163 coins in about 15886 seconds. (4 hours and 24 minutes.) That was with breaks. It was written so shortly on the screen I did not manage to take it down for certain. But after that I read here about the 169 and found that there where at least three in the volcano I had not noticed at first. And it seems likely that there would be three more I have missed. But really fun to explore. I wrote a lot of the transcript along the way (not from the very start though) This I have now posted without any real order in the 1608: Hoverboard/Transcript page. Hope fully a full and useful transcript can emerge from this. I hope my text can be used if not used as it is written at the moment.--Kynde (talk) 02:05, 26 November 2015 (UTC)

Now a complete transcript... Took me about three weeks to get enough time to do that--Kynde (talk) 17:42, 16 December 2015 (UTC)

I thought Atreyu's horse was Artax, not Artex. 198.41.238.32 05:27, 26 November 2015 (UTC)

The beret guy riding a torpedo (/explosive device of some sort) looks like a Dr. Strangeloe tribute to me. 162.158.255.39 (talk) (please sign your comments with ~~~~)

Just added in the 'collision detection' section the text "On a slow connection, it's possible to move into an 'open' area and then the black image loads in and (probably permanently, without tricks) traps you immobile." To expand upon this, if this is a risk to anyone else (I'm reliant on mobile internet, being away from any comparable landline capability) then you need to look out for perfectly horizontal/vertical edges. For example, hovering up the side of the Washington monument and encountering (typically above the 'bricks' line) a completely flat top. Drifting onto that soon gets you embedded in the remaining Monument, somewhere well below the eventual tip. Alternately, drifting sideways over the landscape and discovering a perfectly vertical cliff downwards (just past the bowling pins is a prime location) tempts you to drift down it and then suddenly the solid land 'happens' around you, forcing a page-refresh and restart (though doubtless there's also various console tricks that could be used). The well, also 'opens out', but it's a lie. I've ended up trapped 'in white' below the now closed black blocks that surround the well bottom (and not found any way back up). But if there a 'texture' (like other cliffs) or 'slope' (like the real Monument edge) to the surface, you're probably Ok. It's a genuine surface or wall that you can generally navigate around without fear of being misled. (Or so is my experience.) 162.158.152.227 09:12, 26 November 2015 (UTC)

Doesn't show anything but a blank page on the first generation iPad. 162.158.184.11 10:41, 26 November 2015 (UTC)

I agree with Arch-TK. I have changed the text referring to the source code, since it does not refer to the full sourde code, but just an obfuscated part.--Gamevang (talk) 14:36, 26 November 2015 (UTC)

I can't pass through text, anybody else experiencing this? I remember being able to pass through text without no clip mode earlier, but for some reason not anymore.--173.245.54.36 18:16, 26 November 2015 (UTC)

I found that I can't pass through ANYTHING non-white when using current version of Chrome on an iPad iOS 9.1. Makes the "game" much harder to play. 173.245.63.144 04:23, 29 November 2015 (UTC)

We definitely need a better presentation of interesting objects/locations and their coordinates. Now, we have quite comprehensive multi-level bullet list and a newly-started table. Neither is perfect. We need some form that will show clearly what is where and where it belongs.

Issues to solve:

  • Many objects are large and a single coordinates pair simply don't describe them well. We need a clear presentation form that will allow putting both a single pair and several ones, e.g. top and bottom for thin vertical objects (e.g. poles, The Monument), four corners for objects occupying large swaths etc.
  • Grouping - we need to group objects that belong to an area, like all things within the Star Destroyer etc. Multilevel bullets are ok, but how to do that in a table?
  • Order - within groups and between them, we need some ordering that will organize the entries. For example left-to-right then top-to-bottom or something like that.
  • Coordinates system - the "native" game coordinates are large numbers, and negative values for the y coordinate to boot. Someone proposed setting a new origin and counting from there. I think it's a good idea, but will require a firm decision, rewrite of radar code and recalculating of all coordinates written down so far.

Any ideas? -- 162.158.90.224 09:24, 27 November 2015 (UTC)

If it weren't for so much effort put in already, I think that we could re-class features as follows:
  • All coin locations, and/or links to the locations they are associated with (e.g. "in original game area" and "carried by a quadcopter drone"), if that's not considered 'unfair' to those wanting to actually play the game (without the self-discipline not to browse the list ;).
  • Locations of all characters, certainly all stick-figures, but maybe also 'wildlife' (or automata) of notable types.
  • All monologues/dialogues/labels (albeit that this is almost entirely a subset of the prior list).
  • Other notable landscape (or structural) features that are more than mere 'flavour' (e.g. the T-shaped mushrooms/whatevers to the east, but not random ground-boulders).
  • Notable move-through spots; inclusive of 'sink-into'able waters/magmas (waist-height, neck-height, fully-submerged?), even when not featuring further hidden routes, but excluding vegetation (ground-grasses/tree-trunks) that mostly are pass-throughable.
Some of these are themselves useful references to other items (e.g. "inside front of Blockade Runner" or "beneath eastern stretch of magma") and so can probably be sub-grouped as all items in a given structure ("coins within the initial play area", "characters/speech within the Star Destroyer") and some things do occupy a swathe (the 'play area', the Monument, the ships, the kites, with their strings; the hail of (regular) torpedoes). And I bet there's a whole lot of arguments about what level of detail we could go to... 162.158.152.227 10:21, 27 November 2015 (UTC)

When you deposit 42 coins, the response, "No answers here" is a reference to "Hitchhiker's Guide to the Galaxy."Hax (talk) 162.158.252.149 03:33, 29 November 2015 (UTC)

The full and complete 1608: Hoverboard/Transcript that I have made uses some of the ideas, and groups the stage into sections. Not saying these should be used as is. But all in the image has been described and text transcribed in there. So it would be easy to cut and paste something from them. I have used jump height and fall time as well as time elapsed when moving and the height of the hoverboard Cueball to measure distances/dimensions. I would suggest making pictures from the maps of larger rooms or items. And then zoom in on interesting features. --Kynde (talk) 17:50, 16 December 2015 (UTC)

Where can I get the uncompressed (original) source code? The reason I am asking is, /tigl.js is incomplete (no Easter Eggs, etc.), and /tigl.min.js seems complete, but is unreadable due to "minification" (compression).

162.158.252.149 03:33, 29 November 2015 (UTC)

It's a great comic, but does anyone know what it has to do the with his new book? 198.41.235.161 03:50, 30 November 2015 (UTC)

I've created desktop C++/SDL2 based version of 1608, maybe someone will find it useful: https://github.com/AMDmi3/hoverboard-sdl 162.158.90.212 17:57, 30 November 2015 (UTC)


I'm not sure what the coordinates are, so I'm reluctant to add it to the page proper, but I'm pretty sure Beret Guy riding the bomb near the Tantive IV is a nod to Dr. Strangelove 108.162.218.185 19:17, 30 November 2015 (UTC)


When I try to play the game on my machine (IE10, Win7), I have whole sections that are just straight lined black boxes, almost like a puzzle with pieces missing. The easiest one to find is by going to the left, the quadcopters are hovering over nothing. Is this a java issue, an IE issue, a Windows issue, or just a "shut up and reboot" issue?108.162.216.44 19:19, 30 November 2015 (UTC)

You use IE? Suicide! The Department of Homeland Security considers IE as a threat. 173.245.54.36 22:39, 30 November 2015 (UTC)

Also: If you are using IE, no matter what the problem is, it will always be an IE issue.

  • Stove fire? -- IE issue
  • Alien obduction? -- IE issue

162.158.90.187 12:47, 4 December 2015 (UTC)


Might be useful for exploration of the map: I have made a page that embeds hoverboard with a panel allowing you do perform various cheats and tricks. :) http://php.9kv.cu.cc/hoverboard/ 108.162.216.37 21:42, 1 December 2015 (UTC)

Me Again: Here's a stitched-together image of the map (taken from reddit) with the areas that you can walk through that are normally black highlighted in red: https://www.dropbox.com/s/pnstn4oam15lvgf/hoverboard-collision-map.png?raw=1 108.162.216.37 22:34, 1 December 2015 (UTC)

The full transcript of the entire comic is now complete 1608: Hoverboard/Transcript.--Kynde (talk) 20:03, 15 December 2015 (UTC)

And I just tried it out to finally get all 169 coins and explorer the entire drawing the true way without cheating, in just 1½ hours: 1608:_Hoverboard/Screen-shots#All_169_coins.
And then later I took the shortest route between coins and finished in less than 25 minutes (see same link as above). Seems like I'm the only one still working to complete this comic... --Kynde (talk) 19:39, 28 December 2015 (UTC)

Here is a page with a fully sort-able table of all the links to images: All image links. It includes notes on which images there are people, text, animals, objects of some interest and coins. And it is designed so connecting images can be found by sorting on either locations, general content or the first word in the description. Only 3440 images described. Although more than 1600 of them are completely black and 40 more almost completely black as well as the 800 white. But still there was close to 1000 images left... Enjoy the easy way to find interesting stuff in the images --Kynde (talk) 23:46, 15 January 2016 (UTC)

I got 26 coins and it said "undefined" 108.162.220.227 00:29, 3 March 2016 (UTC)

You are probably using explorer, see the explanation for this above: Messages in Play Area. There even is some examples like this. --Kynde (talk) 14:08, 26 March 2016 (UTC)

Good LORD, why is this still "incomplete"? If you look at the red comments in the table, they are inane and unnecessary. Half of the "Missing Explanation" entries do not even *need* an explanation as the title says exactly what it is. Can we finally close this incomplete explanation?173.245.54.55 14:13, 29 June 2016 (UTC)

  Hi, but what you are saying is that some of the red text is self explanatory. However, some still needs background information. Also, like most comics, things can be read different ways so there can be alternate explanations. If you feel like you need to say something different from the explanation, just edit. There isn't anything that can't be undone with a simple undo here. Dontknow (talk) 04:15, 18 March 2017 (UTC)


Under "Coins", the example says that it's a lamp and a broken lamp. Isn't it a beehive and then the remains of a 'stolen' beehive? Bees buzz. 108.162.221.84 13:49, 29 July 2016 (UTC)

When going through tight passages as Gandalf, rapidly changing direction can cause the game to teleport the character to the room of the Star Destroyer containing two characters swinging through the air. This has happened for me in the well, as well as the passage from Elon Musk's lair to the room containing the universal grounding rod.108.162.216.118 13:15, 29 October 2016 (UTC)

It works on iPad now!

Just noticed that it now runs on my iPad, though it lags often and the controls are awful—even if I'm tilting in the same direction, Cueball moves randomly, and sometimes he just flies in one direction, and there's no way to get him to go up or turn around. Then he gets stuck on something and you have to refresh the page... Which is quite annoying when you're looking for a certain image to explain and you have to start over from the play area. Still, it's better than nothing. Herobrine (talk) 03:32, 16 February 2018 (UTC)

Actually, no, the title text isn't only visible on unofficial mobile viewers. You can see it at m.xkcd.com, which is very much official. 162.158.126.34 03:29, 12 August 2019 (UTC)

Here follows an extensive Latin discussion:

The commentator attempts to explain the motto, "Cur ego committitur dictar latinae."

There is repeated suggestion of 'now' or 'just now' somehow arising from the text. And the commentator makes a beginner's error by suggesting that iustus/justus could be used to mean just as in, just now. English has multiple uses of just - as an adverb speaking about time or exclusivity, and as an adjective talking about right and appropriate. For instance:

Adverb time: "Well that just happened." synonyms: currently, now Adverb exclusive: "Just do it." synonyms: only, merely Adjective: "That was a just choice." synonyms: righteous, appropriate

Iustus (also spelled justus) is a translation of the adjectival form of English just/righteous. So the exmaple the commentator gives: 'Cur ego iustus committitur loquitur.' Would mean: 'Why is the righteous I made to speak.' or, if the adjective is being used as a noun: 'Why am I the righteous/just is made to speak.'

Also, committitur and loquitur in the example are both third person singular, so neither could properly connect to 'ego' (English 'I'). To make sense in the expected way, we would need to put loquo- into the first person singular form at least.

So if the commentator wants to insert the idea of 'just now' or 'currently,' I suggest they use an adverb: 1 recens, 2 jam/iam, 3 nunc, 4 iamiamque/jamjamque 1 recently, 2 now (inprecise), 3 now (this time), 4 now (at once, already, hurry it up man).

On the proper translation: Dictus is a noun meaning word or speech, from the verb 'dico.' If you wanted to specifically imply that you were using audible words (rather than writing), you'd use the 'loquo-' base instead of 'dic-.' So dictus and dico (from dic-) mean 'words' and 'I say.' Dicto is a rarer verb meaning I recite, I dictate, I repeat, or something similar. See: https://en.wiktionary.org/wiki/dicto#Latin The principal forms are dico, dictare, dictavi, dictatum. So we talking about a third declension verb, and the base is dicta-. Dictar would be the first person present passive imperfect. Typically that form would mean something like: 'I am being recited.' But since a person (as a physical object) can't be spoken or recited, the meaning is probably: 'I am being caused/made/forced to recite.' The exact nature of 'caused/made/forced' is described by the word, 'committitur.' The committ- base means commit, begin, or make happen. Committitur is the 3rd person (he/she/it) present passive indicative from: https://en.wiktionary.org/wiki/committitur Meaning: he/she/it is made/forced to. (Has become committed.) So: 'Cur ego committitur dictar latinae' means: 'Why am I being made/forced to recite/dictate in Latin.'

Also, it should be noted that while the Greeks invented many of the types of punctuation we use today, Romans usually only used periods. (And often Romans would use no punctuation at all. Sometimes they even left out the spaces between words.) Point being, the question mark; like the comma, colon, and semicolon; wasn't commonly used until after the introduction of the printing press. So the quote probably shouldn't end with one.

My Latin is rather rusty, so if you have any better suggestions, please send me an email: [email protected]