Talk:1608: Hoverboard

Explain xkcd: It's 'cause you're dumb.
Jump to: navigation, search

Well, this will be the next incomplete explanation for a while. -162.158.90.165 21:58, 24 November 2015 (UTC)

Still working on it now four months later. But not many other helping with it. ;-) Getting closer to the end though with the table in place. --Kynde (talk) 14:10, 26 March 2016 (UTC)

Yes, one thing to note is how to get the hell out of the cave near the volcano 108.162.249.159 22:38, 24 November 2015 (UTC)

The image is made up of small images with addresses of the form http://xkcd.com/1608/XXXX:-YYYY+s.png (although not every coordinate inside the bounds has an image associated). A script could probably dump out all the images and paste them together. --108.162.216.6 22:46, 24 November 2015 (UTC)

West -- Under Lava Pools -- Elon Musk's Secret Volcano Base (not as enjoyable as you might expect).

The Starship out east contains, among other things, Darth Vader, apparently explaining Steven Universe to a subordinate. (Steven and the Crystal Gems can be found a the west end of the ship, near an ice cream cooler.) The same ship contains an elaborate homage to the original Prince of Persia. 162.158.56.5 (talk) (please sign your comments with ~~~~)

There, have at thee an image! Arch-TK (talk) 22:58, 24 November 2015 (UTC)

"teleport to next coin" code doesn't work(insert name here) (talk) 14:47, 21 June 2019 (UTC)

There are 168 coins spread throughout the map according to the source code 173.245.54.53 23:03, 24 November 2015 (UTC)

It's actually 169 coins (t.length). --188.114.111.129 23:22, 24 November 2015 (UTC)

May I change the code for the display distance and direction thing to make the colors more appealing? I want to cheat but I don't want to stare at that yucky green the whole time. 172.69.170.88 17:44, 20 June 2019 (UTC)

When using a device, instead of saying "use arrow keys to move", it says "tilt to move, tap to jump". It's also a lot harder to control. 108.162.250.159 (talk) (please sign your comments with ~~~~)

What kind of device and is this through the normal xkcd home page? It does not work on my tablet by going to xkcd (anroid, leonov tablet). --Kynde (talk) 17:24, 16 December 2015 (UTC)

I got 153 coins!! :D There's two starships, one's a star destroyer with an expansive maze dropping regular torpedoes on the other. May be noteworthy that there are various references to Star Wars and Steven Universe throughout. 108.162.221.13 23:27, 24 November 2015 (UTC)

The second starship is the TantiveIV, Leia's ship at the beginning of episode 4. Note directly below the Tantive, the terrain seems to be sand dunes. Also there are two more space ships by the volcano; an X-wing at a gas station and an Apollo Command Module. 108.162.216.24 (talk) (please sign your comments with ~~~~)

https://xkcd.com/1608/tigl.js - Looks like there's an easier to read version of the code there. Maybe that'll help someone with extracting all the images. {{unsigned ip|

I've got all the images downloaded. Zipping/uploading now. Should I post a link here when complete or what's the best way to share these? I'm also working on setting up a zoomable map. 173.245.54.53 23:57, 24 November 2015 (UTC)

The collision detection is glitchy. I keep landing/bumping against platforms I'm far away from. Is getting stuck against walls normal? --199.27.130.234 00:01, 25 November 2015 (UTC)

Yes, getting stuck against walls is normal. If the wall has at least 1 pixel sticking out under the hoverboard, then that pixel will be treated as the floor, and the hoverboard will stop falling. This is easier to see in goggles mode.108.162.216.118 13:15, 29 October 2016 (UTC)

Tiles are located here in a zip: https://up1.ca/#Gi51KPFyPRELe0T1D6q9Mw All I did was iterate over http://xkcd.com/1608/X:-Y+s.png from X=[916...1116] and Y=[916...1116]. I'm working on putting a zoomable map together. If anyone has interest in helping we could hop on IRC? Jcox (talk) 00:15, 25 November 2015 (UTC)

This was great. But the zip file misses all images in column 1019-1021 as well as the 6 lowest images of 1022 (X coordinates 1019-1022, all Y coordinatesin the first three and then 6 lowest Y coordinates in the last). It was managable to download the last with my click skills. So thanks anyway. --Kynde (talk) 20:15, 28 December 2015 (UTC)

I've written a zsh script to iterate over all possible tiles (does anyone know the height limits? the source only gives the left and right limits) and glue them together into one giant file. I'll upload the results as soon as it's finished. Arch-TK (talk) 00:17, 25 November 2015 (UTC)

I don't think it's limited vertically at all. I found a zoomable map on the reddit topic http://codepen.io/KyleDavidE/full/605dc87b614ff6b2bd716f4c6f640203/ (by kyledavide) Miraries (talk) 00:21, 25 November 2015 (UTC)Mirages

Here's a zoomed out map of all the game area: https://i.imgur.com/rNU9ZgN.png. From luke_in_the_sky at Reddit [1]. --188.114.111.129 00:35, 25 November 2015 (UTC)

Alright, the full png of the entire map is almost finished, I should have used white tiles as blank tiles but I guess I can fix that up in gimp, and I'm not sure how to account for the 1 pixel overlap with just imagemagick convert. The last step is to merge allthe layer images into one giant image, wish my laptop the best of luck! Arch-TK (talk) 01:00, 25 November 2015 (UTC)

Someone beat you to it, but keep on it: that one doesn't have right limit tiles. https://www.reddit.com/r/xkcd/comments/3u4sy1/xkcd_1608_hoverboard/cxc0p8x --188.114.111.129 01:19, 25 November 2015 (UTC)

Perhaps we can change the screenshot at the top to this? It's a quickly hacked overview of the entire map: http://imgur.com/Mz9arHz 199.27.129.167 01:27, 25 November 2015 (UTC)

I think it might make more sense to just add it as another image, mediawiki supports this after all. The syntax should be: [[File:filename.png|thumb|Subtitle|alt=alt]] Arch-TK (talk) 01:34, 25 November 2015 (UTC)


[2] This one loads all of the images quickly (From the xkcd site), and uses browser zooming. 173.245.54.47 01:29, 25 November 2015 (UTC)

The impassible backgrounds are RGB(0,0,0), and the passable ones are RGB(1,1,1). #explore > :first-child {filter:brightness(30);-webkit-filter:brightness(30);-moz-filter:brightness(30);-o-filter:brightness(30);-ms-filter:brightness(30);} ... See https://twitter.com/BadPhysics/status/669354631869304832 108.162.249.155 03:40, 25 November 2015 (UTC)

Here are all the secret passages marked I could find: http://imgur.com/a/fKE1Q --162.158.91.220 00:50, 25 November 2015 (UTC)

I wrote a tampermonkey script that shows you your coordinates and lets you teleport; will make coordinate sharing a lot easier. You do need tampermonkey installed for this to work. Click to install Minerguy31 (talk) 04:17, 25 November 2015 (UTC)

I got 159 coins without the map. If you guys are still wondering how to escape the volcano, move to the right for as long as you think you can, then start spamming the up key while switching between holding the left and right keys. It worked for me on my first try.162.158.252.119 07:06, 25 November 2015 (UTC)

Didn't take down the coordinates, but the layout to the first level of the original Prince of Persia is in there, including the guard standing by with his scimitar! I found it in the ship atop the pyramid east of the play area. --108.162.218.245 06:24, 25 November 2015 (UTC)

Just thought this was interesting, when you "complete" the game by dropping coins, the following line of javascript is run, which sends your result to the server (L is number of coins, z is seconds used): (new Image).src = "//xkcd.com/events.gif?coins=" + L + "&seconds=" + z; Don't be tricked by the .gif extension, it doesn't show an image when opened, and the server probably handles this request by logging it to somewhere. 141.101.80.87 (talk) (please sign your comments with ~~~~)

It actually returns a 1 by 1 pixel white GIF. Arch-TK (talk) 13:14, 25 November 2015 (UTC)

Is there a way that we can merge the "game" part of this comic with the map of 1110: Click and Drag? Allowing us to explore that one in a similar way? Bon (talk) 11:03, 25 November 2015 (UTC)

Well I managed to find (nearly) everything, except the floating rock island, and 162 coins without the map, but even with looking at several maps, I didn't pass any graveyard nor found the way to the grey ocean, which I assume is underneath the "continent". Does anyone know where the entrance is? 162.158.90.218 11:54, 25 November 2015 (UTC)

Search for any missing things in the complete 1608: Hoverboard/Transcript, and you shall find what you seek. --Kynde (talk) 17:40, 16 December 2015 (UTC)

Just thought I should say; the comic supports some alternative movement controls, there's the arrow keys, WASD, and also the vi keys (hjkl), and the numpad (8426). 108.162.242.125 13:29, 25 November 2015 (UTC)

I was not able to get to some points because they were surrounded by text, people or other objects. Is that normal, or are there tricks to get to every coin without using cheats (console)? It would be nice if this could be mention / explained in the article. 162.158.135.35 13:31, 25 November 2015 (UTC)

In some cases you can come in from the side as opposed to trying to come down through or up through something. Example: at the X-Wing "gas station", to get that coin, land on the ground to the left of the X-Wing and move to the right on the ground towards the gas station. Jarod997 (talk) 14:45, 25 November 2015 (UTC)
No text is solid! You can use the full 1608: Hoverboard/Transcript to find out how to get to every coin and place (or the great map linked at the top). --Kynde (talk) 17:40, 16 December 2015 (UTC)

The list of "areas" in the map would be much easier to read, and much easier to correlate with the map, if the origin were set to the starting area (that is, if the coordinates of the starting area were set to x:0, y:0). What is the reason for the very large numbers? --BlueMoonlet (talk) 15:50, 25 November 2015 (UTC)

The large numbers are the actual ones used by the game code and displayed by the hacked-up "radar" so it was a natural choice to use them as they are. We could define some origin and count coordinates from it but we would have to agree on its position and then change the "radar" code and recalculate all coordinates written down already. -- 162.158.90.224 08:53, 27 November 2015 (UTC)
Coordinates is not very helpful to most people. It should more be in relation to the objects you pass. Either you just look at one of the maps (and then past the pyramid or in the volcano makes sense) or else you actually try the real experience, and again after the ocean comes a pyramid makes more sense than coordinates. Have moved this section to a trivia section. The table should be build differently. That is still work to be done. All things are at the moment mentioned in the complete 1608: Hoverboard/Transcript. --Kynde (talk) 17:40, 16 December 2015 (UTC)

The starting area is in no way related to pac-man. The lines are not all right angles, there is a timer, there's gravity, there are no aggressors, you're collecting coins instead of pellets.... Not every line maze is pac-man. This is an erroneous reference that should be removed. --198.41.235.167 17:16, 25 November 2015 (UTC)

The source code found at https://xkcd.com/1608/tigl.js does not seem to be complete. I would personally work on de-obfuscating the full source code using the fragment found there but technically the source is covered by implicit copyright laws and that means that if I published a derived work I would be breaking those laws. Should I just change the line from "The source code can be found at ..." to "The full (obfuscated) source code can be found at ...tigl.min.js and a deobfuscated piece of the source code can be found at ...tigl.js". Arch-TK (talk) 18:28, 25 November 2015 (UTC)

I added quick coordinate / teleport access on right-click to the quick hack map. Kyledavide (talk) 20:45, 25 November 2015 (UTC)

Can't be bothered working out how to edit the page, but the explanation contains the phrase "People holding anchor lines to a Star Destroyer" - they're holding anchor lines to a CR90 Corvette, specifically the Tantive IV, commonly referred to as the "Rebel Blockade Runner", which in turn is being *attacked by* a Star Destroyer. I'll get my coat. 162.158.153.47 (talk) (please sign your comments with ~~~~)

That's no 'Children's Swimming Pool', it's a ball pit! 162.158.2.222 23:46, 25 November 2015 (UTC)

If it is, it's filled with water as well. There are waves on the surface and fish live in it. -- 162.158.90.224 09:00, 27 November 2015 (UTC)

I slightly improved the "direction to next coin"-code by displaying a compas. Code can be found here http://pastebin.com/PL6fv5XK . I'm new to this wiki and don't want to mess up the page, so I didn't put the code in there myself ... --162.158.90.209 00:01, 26 November 2015 (UTC)

Haven't read all the comments above so maybe someone has written about it? If you click up it seems to count how many times. So it will just show white and then when you release again, it will take longer to hit the ground the longer you have pushed up. Tried with 100 clicks (9-10 seconds) and 200 clicks (20 seconds). I got about 163 coins in about 15886 seconds. (4 hours and 24 minutes.) That was with breaks. It was written so shortly on the screen I did not manage to take it down for certain. But after that I read here about the 169 and found that there where at least three in the volcano I had not noticed at first. And it seems likely that there would be three more I have missed. But really fun to explore. I wrote a lot of the transcript along the way (not from the very start though) This I have now posted without any real order in the 1608: Hoverboard/Transcript page. Hope fully a full and useful transcript can emerge from this. I hope my text can be used if not used as it is written at the moment.--Kynde (talk) 02:05, 26 November 2015 (UTC)

Now a complete transcript... Took me about three weeks to get enough time to do that--Kynde (talk) 17:42, 16 December 2015 (UTC)

I thought Atreyu's horse was Artax, not Artex. 198.41.238.32 05:27, 26 November 2015 (UTC)

The beret guy riding a torpedo (/explosive device of some sort) looks like a Dr. Strangeloe tribute to me. 162.158.255.39 (talk) (please sign your comments with ~~~~)

Just added in the 'collision detection' section the text "On a slow connection, it's possible to move into an 'open' area and then the black image loads in and (probably permanently, without tricks) traps you immobile." To expand upon this, if this is a risk to anyone else (I'm reliant on mobile internet, being away from any comparable landline capability) then you need to look out for perfectly horizontal/vertical edges. For example, hovering up the side of the Washington monument and encountering (typically above the 'bricks' line) a completely flat top. Drifting onto that soon gets you embedded in the remaining Monument, somewhere well below the eventual tip. Alternately, drifting sideways over the landscape and discovering a perfectly vertical cliff downwards (just past the bowling pins is a prime location) tempts you to drift down it and then suddenly the solid land 'happens' around you, forcing a page-refresh and restart (though doubtless there's also various console tricks that could be used). The well, also 'opens out', but it's a lie. I've ended up trapped 'in white' below the now closed black blocks that surround the well bottom (and not found any way back up). But if there a 'texture' (like other cliffs) or 'slope' (like the real Monument edge) to the surface, you're probably Ok. It's a genuine surface or wall that you can generally navigate around without fear of being misled. (Or so is my experience.) 162.158.152.227 09:12, 26 November 2015 (UTC)

Doesn't show anything but a blank page on the first generation iPad. 162.158.184.11 10:41, 26 November 2015 (UTC)

I agree with Arch-TK. I have changed the text referring to the source code, since it does not refer to the full sourde code, but just an obfuscated part.--Gamevang (talk) 14:36, 26 November 2015 (UTC)

I can't pass through text, anybody else experiencing this? I remember being able to pass through text without no clip mode earlier, but for some reason not anymore.--173.245.54.36 18:16, 26 November 2015 (UTC)

I found that I can't pass through ANYTHING non-white when using current version of Chrome on an iPad iOS 9.1. Makes the "game" much harder to play. 173.245.63.144 04:23, 29 November 2015 (UTC)

We definitely need a better presentation of interesting objects/locations and their coordinates. Now, we have quite comprehensive multi-level bullet list and a newly-started table. Neither is perfect. We need some form that will show clearly what is where and where it belongs.

Issues to solve:

  • Many objects are large and a single coordinates pair simply don't describe them well. We need a clear presentation form that will allow putting both a single pair and several ones, e.g. top and bottom for thin vertical objects (e.g. poles, The Monument), four corners for objects occupying large swaths etc.
  • Grouping - we need to group objects that belong to an area, like all things within the Star Destroyer etc. Multilevel bullets are ok, but how to do that in a table?
  • Order - within groups and between them, we need some ordering that will organize the entries. For example left-to-right then top-to-bottom or something like that.
  • Coordinates system - the "native" game coordinates are large numbers, and negative values for the y coordinate to boot. Someone proposed setting a new origin and counting from there. I think it's a good idea, but will require a firm decision, rewrite of radar code and recalculating of all coordinates written down so far.

Any ideas? -- 162.158.90.224 09:24, 27 November 2015 (UTC)

If it weren't for so much effort put in already, I think that we could re-class features as follows:
  • All coin locations, and/or links to the locations they are associated with (e.g. "in original game area" and "carried by a quadcopter drone"), if that's not considered 'unfair' to those wanting to actually play the game (without the self-discipline not to browse the list ;).
  • Locations of all characters, certainly all stick-figures, but maybe also 'wildlife' (or automata) of notable types.
  • All monologues/dialogues/labels (albeit that this is almost entirely a subset of the prior list).
  • Other notable landscape (or structural) features that are more than mere 'flavour' (e.g. the T-shaped mushrooms/whatevers to the east, but not random ground-boulders).
  • Notable move-through spots; inclusive of 'sink-into'able waters/magmas (waist-height, neck-height, fully-submerged?), even when not featuring further hidden routes, but excluding vegetation (ground-grasses/tree-trunks) that mostly are pass-throughable.
Some of these are themselves useful references to other items (e.g. "inside front of Blockade Runner" or "beneath eastern stretch of magma") and so can probably be sub-grouped as all items in a given structure ("coins within the initial play area", "characters/speech within the Star Destroyer") and some things do occupy a swathe (the 'play area', the Monument, the ships, the kites, with their strings; the hail of (regular) torpedoes). And I bet there's a whole lot of arguments about what level of detail we could go to... 162.158.152.227 10:21, 27 November 2015 (UTC)

When you deposit 42 coins, the response, "No answers here" is a reference to "Hitchhiker's Guide to the Galaxy."Hax (talk) 162.158.252.149 03:33, 29 November 2015 (UTC)

The full and complete 1608: Hoverboard/Transcript that I have made uses some of the ideas, and groups the stage into sections. Not saying these should be used as is. But all in the image has been described and text transcribed in there. So it would be easy to cut and paste something from them. I have used jump height and fall time as well as time elapsed when moving and the height of the hoverboard Cueball to measure distances/dimensions. I would suggest making pictures from the maps of larger rooms or items. And then zoom in on interesting features. --Kynde (talk) 17:50, 16 December 2015 (UTC)

Where can I get the uncompressed (original) source code? The reason I am asking is, /tigl.js is incomplete (no Easter Eggs, etc.), and /tigl.min.js seems complete, but is unreadable due to "minification" (compression).

162.158.252.149 03:33, 29 November 2015 (UTC)

It's a great comic, but does anyone know what it has to do the with his new book? 198.41.235.161 03:50, 30 November 2015 (UTC)

I've created desktop C++/SDL2 based version of 1608, maybe someone will find it useful: https://github.com/AMDmi3/hoverboard-sdl 162.158.90.212 17:57, 30 November 2015 (UTC)


I'm not sure what the coordinates are, so I'm reluctant to add it to the page proper, but I'm pretty sure Beret Guy riding the bomb near the Tantive IV is a nod to Dr. Strangelove 108.162.218.185 19:17, 30 November 2015 (UTC)


When I try to play the game on my machine (IE10, Win7), I have whole sections that are just straight lined black boxes, almost like a puzzle with pieces missing. The easiest one to find is by going to the left, the quadcopters are hovering over nothing. Is this a java issue, an IE issue, a Windows issue, or just a "shut up and reboot" issue?108.162.216.44 19:19, 30 November 2015 (UTC)

You use IE? Suicide! The Department of Homeland Security considers IE as a threat. 173.245.54.36 22:39, 30 November 2015 (UTC)

Also: If you are using IE, no matter what the problem is, it will always be an IE issue.

  • Stove fire? -- IE issue
  • Alien obduction? -- IE issue

162.158.90.187 12:47, 4 December 2015 (UTC)


Might be useful for exploration of the map: I have made a page that embeds hoverboard with a panel allowing you do perform various cheats and tricks. :) http://php.9kv.cu.cc/hoverboard/ 108.162.216.37 21:42, 1 December 2015 (UTC)

Me Again: Here's a stitched-together image of the map (taken from reddit) with the areas that you can walk through that are normally black highlighted in red: https://www.dropbox.com/s/pnstn4oam15lvgf/hoverboard-collision-map.png?raw=1 108.162.216.37 22:34, 1 December 2015 (UTC)

The full transcript of the entire comic is now complete 1608: Hoverboard/Transcript.--Kynde (talk) 20:03, 15 December 2015 (UTC)

And I just tried it out to finally get all 169 coins and explorer the entire drawing the true way without cheating, in just 1½ hours: 1608:_Hoverboard/Screen-shots#All_169_coins.
And then later I took the shortest route between coins and finished in less than 25 minutes (see same link as above). Seems like I'm the only one still working to complete this comic... --Kynde (talk) 19:39, 28 December 2015 (UTC)

Here is a page with a fully sort-able table of all the links to images: All image links. It includes notes on which images there are people, text, animals, objects of some interest and coins. And it is designed so connecting images can be found by sorting on either locations, general content or the first word in the description. Only 3440 images described. Although more than 1600 of them are completely black and 40 more almost completely black as well as the 800 white. But still there was close to 1000 images left... Enjoy the easy way to find interesting stuff in the images --Kynde (talk) 23:46, 15 January 2016 (UTC)

I got 26 coins and it said "undefined" 108.162.220.227 00:29, 3 March 2016 (UTC)

You are probably using explorer, see the explanation for this above: Messages in Play Area. There even is some examples like this. --Kynde (talk) 14:08, 26 March 2016 (UTC)

Good LORD, why is this still "incomplete"? If you look at the red comments in the table, they are inane and unnecessary. Half of the "Missing Explanation" entries do not even *need* an explanation as the title says exactly what it is. Can we finally close this incomplete explanation?173.245.54.55 14:13, 29 June 2016 (UTC)

  Hi, but what you are saying is that some of the red text is self explanatory. However, some still needs background information. Also, like most comics, things can be read different ways so there can be alternate explanations. If you feel like you need to say something different from the explanation, just edit. There isn't anything that can't be undone with a simple undo here. Dontknow (talk) 04:15, 18 March 2017 (UTC)


Under "Coins", the example says that it's a lamp and a broken lamp. Isn't it a beehive and then the remains of a 'stolen' beehive? Bees buzz. 108.162.221.84 13:49, 29 July 2016 (UTC)

When going through tight passages as Gandalf, rapidly changing direction can cause the game to teleport the character to the room of the Star Destroyer containing two characters swinging through the air. This has happened for me in the well, as well as the passage from Elon Musk's lair to the room containing the universal grounding rod.108.162.216.118 13:15, 29 October 2016 (UTC)

It works on iPad now!

Just noticed that it now runs on my iPad, though it lags often and the controls are awful—even if I'm tilting in the same direction, Cueball moves randomly, and sometimes he just flies in one direction, and there's no way to get him to go up or turn around. Then he gets stuck on something and you have to refresh the page... Which is quite annoying when you're looking for a certain image to explain and you have to start over from the play area. Still, it's better than nothing. Herobrine (talk) 03:32, 16 February 2018 (UTC)

Actually, no, the title text isn't only visible on unofficial mobile viewers. You can see it at m.xkcd.com, which is very much official. 162.158.126.34 03:29, 12 August 2019 (UTC)

Here follows an extensive Latin discussion:

The commentator attempts to explain the motto, "Cur ego committitur dictar latinae."

There is repeated suggestion of 'now' or 'just now' somehow arising from the text. And the commentator makes a beginner's error by suggesting that iustus/justus could be used to mean just as in, just now. English has multiple uses of just - as an adverb speaking about time or exclusivity, and as an adjective talking about right and appropriate. For instance:

Adverb time: "Well that just happened." synonyms: currently, now Adverb exclusive: "Just do it." synonyms: only, merely Adjective: "That was a just choice." synonyms: righteous, appropriate

Iustus (also spelled justus) is a translation of the adjectival form of English just/righteous. So the exmaple the commentator gives: 'Cur ego iustus committitur loquitur.' Would mean: 'Why is the righteous I made to speak.' or, if the adjective is being used as a noun: 'Why am I the righteous/just is made to speak.'

Also, committitur and loquitur in the example are both third person singular, so neither could properly connect to 'ego' (English 'I'). To make sense in the expected way, we would need to put loquo- into the first person singular form at least.

So if the commentator wants to insert the idea of 'just now' or 'currently,' I suggest they use an adverb: 1 recens, 2 jam/iam, 3 nunc, 4 iamiamque/jamjamque 1 recently, 2 now (inprecise), 3 now (this time), 4 now (at once, already, hurry it up man).

On the proper translation: Dictus is a noun meaning word or speech, from the verb 'dico.' If you wanted to specifically imply that you were using audible words (rather than writing), you'd use the 'loquo-' base instead of 'dic-.' So dictus and dico (from dic-) mean 'words' and 'I say.' Dicto is a rarer verb meaning I recite, I dictate, I repeat, or something similar. See: https://en.wiktionary.org/wiki/dicto#Latin The principal forms are dico, dictare, dictavi, dictatum. So we talking about a third declension verb, and the base is dicta-. Dictar would be the first person present passive imperfect. Typically that form would mean something like: 'I am being recited.' But since a person (as a physical object) can't be spoken or recited, the meaning is probably: 'I am being caused/made/forced to recite.' The exact nature of 'caused/made/forced' is described by the word, 'committitur.' The committ- base means commit, begin, or make happen. Committitur is the 3rd person (he/she/it) present passive indicative from: https://en.wiktionary.org/wiki/committitur Meaning: he/she/it is made/forced to. (Has become committed.) So: 'Cur ego committitur dictar latinae' means: 'Why am I being made/forced to recite/dictate in Latin.'

Also, it should be noted that while the Greeks invented many of the types of punctuation we use today, Romans usually only used periods. (And often Romans would use no punctuation at all. Sometimes they even left out the spaces between words.) Point being, the question mark; like the comma, colon, and semicolon; wasn't commonly used until after the introduction of the printing press. So the quote probably shouldn't end with one.

My Latin is rather rusty, so if you have any better suggestions, please send me an email: [email protected]